Jump to content

Recommended Posts

I have been having this problem for awhile now with GTA4 and also the add-ons Gay Tony and the Lost (both on Steam), where the first 30 seconds will run normally and then all of a sudden the games frames will start stuttering no effect on audio. I thought it was the first laptop's specs which were just minimum specs but after loading the game on a second computer found the same issue. It does not matter what graphical settings are selected, same result. After checking all connected hardware and tweaking all settings I found that it was the controller (Microsoft 360 wireless) that was causing the delayed lag. Playing with just the keyboard lag never comes. Anybody have an idea on what this issue is or a fix.? BTW this is on Windows 10 i5 quad 8GB Intel HD 4400. I swapped out 2 controllers and two wireless adapters same result.

Share this post


Link to post
Share on other sites

I'm having the exact same problem, game runs fine without controller but as soon as I use controller about 30 secs - 1 min the game will start stuttering like mad.

 

I don't suppose you found a fix?

Share this post


Link to post
Share on other sites

How to fix choppiness and stutters in GTA IV Complete Edition 2020 v1.2.0.32 in Windows 10

renderTimingPixel.png

If your game starts OK but stutters like crazy when you’re driving in Algonquin near the park or flying in a helicopter near a bridge, read on.

After some research I came to the conclusion that the game itself is not the culprit here and choppiness/stutter is clearly a renderer issue as many people report that enabling steam overlay helped them and – surprise - DXVK works magic on GTA IV, e.g. even translating Direct3D calls to Vulkan is faster and has consistent fps+frametime! So I researched further and found that this crappy legacy D3D/DDraw renderer problem is very common with older games. It is usually solved by:

  1. Fixing native Windows D3D9 renderer with DDrawCompat – game looks as intended, gameplay is pretty smooth

  2. Avoiding crappy native renderer altogether and translating output to superior DX11, OpenGL or Vulkan renderers – game looks nearly as intended, gameplay is silky smooth, 3-5 fps may be lost in translation 8) but DXVK method may even yield fps!

I tried different methods from two groups above with GTA IV and they were the only reliable ones that helped to achieve smooth gameplay and consistent frametime in Algonquin.

So here’s quick-n-dirty method that fixes native D3D renderer

  • Install Ultimate ASI Loader (already installed in FitGirl repack)

  • Download dxwrapper, unpack dxwrapper.asi/.ini into GTA IV folder or plugins subfolder

  • Edit dxwrapper.ini
    [Compatibility]
    DDrawCompat = 1

  • ATTENTION: DDrawCompat on multi-core CPU will load 1st core at 100% by default. To load cores evenly the following must be enabled in dxwrapper.ini:
    [DDrawCompat]
    DDrawCompatNoProcAffinity = 1

  • Optionally may enable antialiasing here if it is not already enabled in nVidia/AMD driver settings:
    [d3d9]
    AntiAliasing = 1

For extensive research of different methods to fix choppiness and stutters in GTA IV see my blog post

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×