Jump to content

Need some help

Recommended Posts

i've resently added GTA SA to my laptop and wanted to mod it. I also did not feel like going through the game all over again so I downloaded a Save Game mod so I would not have to go through it all but when I load the game and get right after the loading screen is finished it crashes. I tried to find other ways to fix this problem and nothing seems to have worked yet.

Share this post

Link to post
Share on other sites

your game is the wrong version i think. or you downloaded a wrong version savegame.

get the downgrader here.

you can tell your version if you look at the bottom right corner, if its v1 it will say nothing otherwise it will say v1.01 or v2.0


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now